Package has been Ignored because it contains Invalid Configuration React Native Error Fix

Last Updated on September 18, 2019.

As a react native developer we face many kind of react native errors while developing apps. Sometimes you may come up with a warning in the terminal as given below:
warn Package @react-native-community/async-storage has been ignored because it contains invalid configuration. Reason: Cannot find module ‘@react-native-community/async-storage/package.json’

The package name may vary with the third party libraries you are installed in the app

This react native warning will finally leads to build error while trying to run your application. So, how to fix this particular error? All you need is to run npm install command on your terminal from your project folder. After that try running your project again using either react-native run-android or react-native run-ios command.

5 thoughts on “Package has been Ignored because it contains Invalid Configuration React Native Error Fix”

  1. This tutorial worked for me, thanks a lot!

    I got this error message:
    warn Package react-native-maps has been ignored because it contains invalid configuration. Reason: Cannot find module ‘react-native-maps\package.json’

    Solution:
    run npm install in terminal

Leave a Reply to Liso Nyandu Cancel reply

%d bloggers like this: